·
This issue has been resolved
Resolved
Monitoring
We have identified the cause of the situation and deployed a fix
Investigating
We are currently investigating downtime across all Indicia Services.